I don't think so, no. I've been prompted for updates twice previously by the alpha build, but just manually forced an update check, and it tells me I have the latest version.